Welcome to Twocanoes Knowledge Base

The Twocanoes forum is the best place to find information about Winclone, Boot Runner, or any other software. Post a question or share information about Twocanoes Software products. We will attempt to answer any unanswered questions within 2-3 business days. If you need an answer more quickly, consider upgrading to Pro Support for 1 business day response time. Winclone can be upgraded to Winclone Pro right in the app.

If you have Winclone Pro, submit a request on the Pro Support page.

Our knowledge base has moved.


Solution for non-functional keyboard and mouse after Windows 7 Boot Camp restore

Windows 7 does not include default USB3 drivers, so when restoring Windows 7 Boot Camp to newer Mac hardware that relies on USB3 for keyboard and mouse, you may find no user input control to proceed with installing Boot Camp drivers.  The following guide explains a workaround for resolving this issue.  

There is a quicker fix that may or may not work, but worth trying first.  See "Set Boot Mode" support document for details.

TL;DR: Boot from a virtual machine, set up auto-install of USB3 drivers, then boot directly into Boot Camp.

Virtual machine hosts on OS X include Parallels, VMWare Fusion and Oracle VM Virtualbox.  Use the vendor support information for installing the vm and linking it to Boot Camp.  If you have never used a virtual machine previously, you may find that you prefer the convenience of using Windows within OS X.  However, this solution uses the virtual machine as a temporary measure to get device drivers installed so Boot Camp is functional when booted directly from the hardware.

Please note that this solution applies to Windows 7 loss of keyboard and mouse control.  This solution is not applicable for Windows 8 or above.

Using Boot Camp Assistant on the same Mac that contains the Boot Camp partition, download the latest Windows support software from Apple to a USB flash drive.

Start up Boot Camp as a virtual machine.

Attach the USB flash drive containing the Boot Camp drivers.

From the virtual machine Windows desktop, copy the $WinPEDriver$ directory from the Boot Camp folder on the flash drive to the Windows desktop.

Copy the remaining Boot Camp drivers directory to the desktop (for convenience in installing later)

In Windows, uninstall Boot Camp from Control Panel-> Programs and Features. The drivers and Boot Camp program will be reinstalled later.  If the uninstall fails, use the Microsoft Fixit tool to remove Boot Camp from Windows:  https://support.microsoft.com/mats/windows_file_and_folder_diag/en-us

Setup the administrator account to auto-login at boot. This tutorial explains how to set this account for auto-login: http://www.sevenforums.com/tutorials/377-log-automatically-startup.html

Disable UAC.  The tutorial linked below refers to the "Vista" operating system but is equally applicable to Windows 7:


Create a shortcut for the "Setup.exe" located in $WinPEDriver$\IntelxHCISetup\ and place the shortcut file in the Run-> Startup folder. Right click the $WinPEDriver$\IntelxHCISetup\Setup.exe file and select Properties. At the end of the string in the Target field, add "-s", which will install the driver in silent mode.

NoteIf you cannot find a Target field in the Properties of the Setup.exe file, it may be necessary to add the “-s” in the Target field of the shortcut file placed in the Run-> Startup folder instead.

Shut down the virtual machine.  Restart the Mac while holding the Option key and select BOOTCAMP as the startup volume. 

If everything was configured correctly as described above, Windows should automatically log in to the administrator account and run the setup for the USB drivers, thus enabling keyboard and mouse control.

With user interface control restored, you may proceed with installing Boot Camp from BOOTCAMP\setup.exe which should install the remaining drivers and have a fully functional Boot Camp system.

As a final cleanup step, re-enable UAC, password-required, etc.

The above workaround is not directly related to Winclone, but if you have questions we will do our best to answer.  Contact us at support@twocanoes.com

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request


  • Avatar
    Patrick Kelly

    Thank you very, very, very much for writing up this solution. It worked. I was in contact with the TwoCanoes help desk almost two years ago when I used Winclone to migrate Windows 7 from my older mac. So, it is great to finally have this fixed.

    In case it matters to anyone:

    "Using Boot Camp Assistant on the same Mac that contains the Boot Camp partition, download the latest Windows support software from Apple to a USB flash drive."

    If you are using a virtual machine there is no need for the USB - you can download the software on the Mac side and copy it over to the Windows desktop in the Virtual machine. In my case this was necessary because in addition to problems with the key board and mouse drivers, the USB ports didn't work either.

    Thanks again.

  • Avatar
    Brendan McDonnell

    This really is a pain. Working as an IT guy at a college trying to deploy Windows images with your software has become not worth it at this point. You just asked me to use other virtualization software to make your software work correctly. This needs a fix or you need to refund people.

  • Avatar
    Russell Scheil

    Not really, the issue is that Windows 7 doesn't come stock with USB3 drivers which the new Macs depend on for keyboard and mouse control. We're suggesting a workaround for a problem that exists with or without the involvement of Winclone imaging. Windows 8 and 10 operating systems do contain USB3 drivers and are not affected by this issue.

  • Avatar
    Betsy Reader

    I totally disagree, Brendon. I also work as an IT Professional for a large school district. This product has been a lifesaver for me! Thank you twocanoes for this amazing product! Winclone is worth every penny (the alternative would be spending even more tax dollars for new hardware or software- not exactly fiscally responsible). This fix worked like a charm and I can quickly finish installing windows 7 in this lab and the students now have the option of using windows or mac, not just one or the other.

  • Avatar
    Moe Miller

    When i try to "set boot mode" i just get this after writing the first words in the terminal: permission denied. How can i fix this ? :)

  • Avatar
    Givano Ramadhan

    Thank you for writing this helpful article.

    I did the steps one by one till get stuck on " installing intelxhcisetup ". The problem is that intelxhcisetup not exist in $WinPEDriver$ folder. FYI i downloaded Bootcamp Support Software 5.1.5621 for my Macbook Air 11" (https://support.apple.com/kb/DL1720?locale=en_US) , maybe thats the reason why the intelxhci is not exist in same folder as you mentioned above. Then i moved to Bootcamp folder (the other folder beside $WinPEDriver$ folder) > Drivers > Intel aaandd voila ! that freakin intelxhci laying cutely in that folder.

  • Avatar
    Ryan O'Malley

    Hi! Thanks so much for posting this. I think I am very close. I am stuck on the step that says:

    Right click the $WinPEDriver$\IntelxHCISetup\Setup.exe file and select Properties. At the end of
    the string in the Target field, add "-s", which will install the driver in silent mode.

    Note: If you cannot find a Target field in the Properties of the Setup.exe file, it may be necessary to
    add the “-s” in the Target field of the shortcut file placed in the Run-> Startup folder instead.

    I can only find the Target field in the Properties of the short cut file. When I add the "-s" to the end of the string in the Target field in the short cut's properties window, it says:

    Problem with Shortcut
    The name 'C:\Users\Ryan\Desktop\$WinPEDriver$\IntelxHCISetup\Setup.exe-s' is specified in
    the Target box is not valid. Make sure the path and file name are correct.

    I tried shutting down the VM and iOS, rebooting in Windows 7 and I got further than before. I see the driver install window, but I am unable to move the mouse or use the keyboard. Any ideas?


  • Avatar
    Ryan O'Malley

    Oops, I am dumb. There should be a space between the 'C:\Users\Ryan\Desktop\$WinPEDriver$\IntelxHCISetup\Setup.exe' and the '-s'.

    Works great! Thanks!

Powered by Zendesk